NOTICE: Deprecation of support for Android 4.4 (KitKat)

July 18, 2018:

Currently, the XY Find It app, used in conjunction with XY Finder models XY2, XY3, XY4, and XYGPS and their sub-models, can be used on phones with Android 4.4 and later.

Upcoming and future versions of the XY Find It app for Android will have the minimum system requirement of Android 5.0 or later.

We're excited about this change. BLE (Bluetooth Low Energy), the technology used in XY Finders, was first introduced in Android 4.3, but the integration of the technology improved significantly with later versions. We believe XY Find It users will have the best possible experience using Android phones with a minimum of Android 5 (Lollipop), and we can achieve the best possible results for our users by basing our software on contemporary operating systems.

We apologize for any inconvenience. If you need any assistance, please contact us here.

Was this article helpful?
6 out of 7 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.